New Router, Now Receipt Printer Doesn't Work (POS)

Running Point of Success and installed a new router. Now my receipt printer doesn’t work, but my box label printer in the kitchen still does. Put my old router back in and everything works fine.


What kind of interface is it (ethernet, USB, serial) and is it the same type of interface as the one that is still working?

Receipt printer is ethernet, the other is USB.

Does the printer have a static IP address or is it set to dynamic and use the DHCP server of your router?

I suspect it is set to dynamic - and that your old router was set up to serve the printers MAC address a specific IP address. The new router is serving it a random address from the pool.

Is it an Espon TM-XX printer? If so - there is a little “hidden” button on the back - push and hold it in with a pen or something and it will print the setup information. Do this when it is connected to your old router - and do it with it connected to the new router. Compare the IP addresses.

Yeah, definitely a problem with the addressing since your USB printer is working.

My guess is that your printer is set with a static IP address and it is outside the range of your new router’s addressing.

If your printer has an IP address of, say, it won’t work if your router is assigning LAN addresses in the 192.168.1.X range.

You’ll need to check a few things to get it working, but it will be an easy fix.

Yes, or as piper is saying it could be the opposite of my first post - that the printer is using a static address, and the PC’s on the network are using dynamic addresses. That is probably more likely.

Check the old router and see what address range it is serving - and change the new router to serve the same addresses. If that doesn’t fix the problem, then we can take it from there.

Ok, this stuff makes my face hurt. My brother is a networking wiz, but it has now landed him a sweet government gig so he doesn’t have time for my little problems anymore.

Going in early tomorrow to push some buttons and find me some IP addresses. Hope it all goes well, found a way to use T-Mobile @ home service and Google Voice to have 6 lines (way more than what I need) for the same price that AT&T is charging me for just one line.

If its an epson TM-T88III, turn the printer off, hold down the feed button, and turn it back on. It should print a self test page with the relevant info.

What router did you use to have and what router do you have now?

for that printer that does not work, you should have an install CD or you can go to the MFG website and get the install for it… the install should auto look for the printer on your network and install it by itself. Then you should be good to go.

I had an issue with my new Star 100future prnt ethernet printer… it would see the printer but not print… i just had to turn the printer off and let it sit for about 10 minutes, turn it back on, and reinstall the software driver for it and it’s worked perfect ever since.

I was trying to switch to a Linksys router from a Belkin. I reset my Belkin this morning to the manufacturer defaults because one of my ex employees put the wrong password in and got himself fired before I realized it.

I’m fairly certain that you guys are correct with the IP address being wrong. It’s an Epson T88III and did not come with an install disk. It was configured for an IP address of and I cannot get it to reset, even after deleting and downloading new drivers and reinstalling.

The router is currently IP and I set the printer to when I added the new port after reinstalling the driver, however when I run the diagnostic print out, it still shows the old IP of

ah an Epson… I changed my Epson 220 to a Ethernet a few weeks back, the IP for the printer was set on the ethernet card in the printer from the factory, so i do not believe you can change it.
Never the less, all I had to do was go to (I’m using Windows 7) Windows > Start > Printers > Add New Printer > Network Printer > wait for windows to see the printer, and if it does not just enter the IP and it should see it.

If not, open your router config and see if there is anything else with that same address… if there is then change the IP of the other device, then connect the printer again.

Here’s how I’ve done this in the past:

  1. Install the driver software.

  2. Temporarily change the address of your router to You can do this by going into the configuration for the router. Type into your browser. The default login for Linksys routers is “admin” and “admin”. It will be on the first page of the configuration screen under “Local IP Address.” Save the configuration. Reset your computers network adapter so it gets a new IP address from the router. Right click on the connection, select “Disable” and then go back in and “Enable” it.

Note: This will allow your computer to communicate with the printer, but will probably disable the rest of your network temporarily. Don’t mess with it while you’re busy.

  1. Type into your web browser. The printer’s configuration screen will come up and you’ll be able to change the IP address. Change it to Save the configuration.

  2. Go back into your router’s configuration and reset the Local IP Address to Reset your computer’s network adapter just like in step 2.

That should do it. Alternatively, you could also just leave your router’s IP address at That will put it in the correct range for the printer (you won’t have to change the printer’s IP address) but may leave you problems with the rest of your network. If your network is configured with DHCP you’ll need to restart the network adapters (or the computer) and let it pull a new IP address. If your network is configured with static IP addresses you’ll need to re-configure each one.

Edit: Changed step three, original post was incorrect. And the more I think about it, the more I think my “alternatively” above is the easiest way to do this. It’s probably how it was configured before if your printer was working. If you’re not 100% comfortable with computers, just change the Router’s IP address to and restart all of your computers.

That’s what it was, thanks Piper and everyone else. :smiley:

It amuses me that you guys helped me get this resolved before I even got a comment on the exact same post on the POS support board. TT wins again!